Microsoft Reporting Issues With Office 365
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 18:48 EDT
Investigating
At 10/07/2020 02:48 PM EDT an issue was detected with Office 365.  Microsoft acknowledges issue with Office 365.  Updates may be found here:  status.office.com
Posted Oct 07, 2020 - 15:22 EDT