Duo Incident - Delayed SMS Message Delivery to some US numbers
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 22:42 EST
Update
See status.duo.com for updates
Posted Nov 25, 2022 - 20:02 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2022 - 19:19 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 25, 2022 - 13:54 EST
Identified
We have identified an issue causing SMS deliveries to some US Numbers are delayed due to carrier congestion. We have made some changes to routing to improve delivery as much as possible while working with our providers on recovery of services.
Posted Nov 25, 2022 - 13:43 EST
This incident affected: Identity Access Management (Duo Two-Step Verification).