Davis Library Experiencing Power Issues
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 16:06 EDT
Investigating
There are ongoing power issues that are impacting parts of Davis Library. Appropriate campus electrical teams and building maintenance techs are aware of the situation and working to resolve it. No ETA at this time on when this will be resolved fully.
Posted Jun 20, 2022 - 13:52 EDT
This incident affected: Other Services.