Verizon Phone Outage
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 12:24 EDT
Investigating
Approximately 5000 Verizon phones are having problems that impact both in-bound and out-bound calls. ITS staff are working with Verizon to resolve the issue.
Posted Sep 14, 2021 - 11:52 EDT
This incident affected: Network (Voice Messaging).