Campus Network
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Aug 22, 2019 - 08:30 EDT
Investigating
ITS is currently investigating problems with the Campus Network. Updates will be communicated as they become available.
Posted Aug 22, 2019 - 08:10 EDT
This incident affected: Network (Campus Location(s)).