Giles Horney Network Connectivity
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 16:43 EST
Investigating
We are experiencing a network outage in the Giles Horney Building. ITS is working to restore service. Updates will be posted as they become available.
Posted Jan 23, 2020 - 16:08 EST
This incident affected: Network (Campus Location(s)).