Campus Service Desk phone number, 919-962-4357 (HELP), is currently unavailable.
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 15:37 EDT
Monitoring
The phone number for the Service Desk is now functional. We will continue to monitor the situation.
Posted Jul 28, 2022 - 12:32 EDT
Identified
The phone number for the Campus Service Desk, 919-962-4357 (HELP), is currently unavailable. Support can be reached at help.unc.edu. Work in progress to rectify this issue. Updates will be provided as information becomes available.
Posted Jul 28, 2022 - 12:19 EDT
This incident affected: Other Services.