Google Fiber
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 10:41 EDT
Identified
MCNC has confirmed this issue and is reporting that other organizations are seeing similar problems. The problem is occurring outside the UNC network somewhere in the network path between Google Fiber users and campus.
Posted Jun 25, 2020 - 09:46 EDT
Investigating
Some Google Fiber customers are reporting issues connecting to UNC services. ITS staff are investigating.
Posted Jun 25, 2020 - 09:25 EDT
This incident affected: Other Services.