Power Outage Impacting Carrington Hall, Botanical Gardens and Outdoor Education Center
Incident Report for UNC Chapel Hill - ITS
Resolved
Power has been restored to these locations at this time.
Posted Jul 23, 2020 - 20:35 EDT
Investigating
There is a power outage that is currently impacting Carrington Hall, Botanical Gardens and Outdoor Education Center. Botanical Gardens and Outdoor Education are part of a larger Duke Power outage.
Posted Jul 23, 2020 - 20:21 EDT
This incident affected: Network (Campus Location(s), Remote Location(s)).