Possible Issue Detected with ConnectCarolina HR

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

All Connect Carolina services are back online.

Posted Oct 27, 2025 - 08:23 EDT

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Oct 27, 2025 - 07:36 EDT
This incident affected: ConnectCarolina (ConnectCarolina HR).