Virtual Lab Application Launch Problems

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.
Posted Mar 02, 2026 - 12:57 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2026 - 21:32 EST

Investigating

We are aware of problems launching applications within the Virtual Lab (Citrix) environment. ITS engineers are working with the vendor to troubleshoot. Additional information will be published as it becomes available.
Posted Feb 28, 2026 - 19:45 EST
This incident affected: Virtual Lab.