Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 13, 2026 - 06:15 EST
Scheduled
The Software Distribution application, which includes purchase punchout from BuyCarolina, will be unavailable February 13th, from 6:30am-7:30am. The Software Distribution punchout in BuyCarolina and program interfaces will receive errors during this time. Please plan accordingly.
Posted Feb 12, 2026 - 16:42 EST
This scheduled maintenance affected: Other Services.