Users experiencing Outlook connection issues and crashes
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.

Microsoft states that while they have deployed the fix, "Users that are still impacted may need to restart their Outlook client for the fix to take effect."
Posted Jul 15, 2020 - 17:47 EDT
Update
Update from Microsoft:

"We've identified the probable cause of the issue and are applying fixes. We've confirmed that our fixes are effective and users will experience service restoration as our solution reaches their respective environments; however, deployment to all affected users may take several hours to complete."
Posted Jul 15, 2020 - 14:50 EDT
Investigating
At 07/15/2020 12:49 PM EDT an issue was detected with Office 365.

Microsoft has posted the following:
Users may experience crashes or may be unable to access Exchange Online via Outlook. Current status: We're analyzing the available data to isolate the source of the problem. Scope of impact: This issue may potentially affect any of your users attempting to use Outlook.
Posted Jul 15, 2020 - 13:29 EDT
This incident affected: Office 365.