Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2026 - 05:00 EDT
Scheduled
Maintenance on ITS-Manning Tier1 will result in a brief outage lasting one to five minutes. The following buildings will be impacted:
The Dillon The Spangler Center CD Spangler and Annex Europa Center The Woody Durham Media and Communications Center School of Business Charlotte Information Technology Services Building Manning Business School Parking Deck Cogeneration Administration Gore Building IMS Coastal Processes Environmental Health Lab
Posted Jul 08, 2026 - 09:23 EDT
This scheduled maintenance affected: Other Services.