Due to unforeseen circumstances, a new ETR of 10:30pm has been established.
Posted Jan 16, 2026 - 21:00 EST
Update
The telecom vendor is expecting repair to be completed by 9pm.
Posted Jan 16, 2026 - 19:25 EST
Identified
The ISP has identified a network issue impacting this site.
Posted Jan 16, 2026 - 15:36 EST
Investigating
Our monitoring tools have indicated a possible network issue at IMS Coastal Processes Environmental Health Lab. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Jan 16, 2026 - 10:00 EST
This incident affected: Network (Campus Building Networks).