TeamDynamix Work Management will be unavailable during the following maintenance window while we perform preparation work for the upcoming 1

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Completed - The scheduled maintenance has been completed

Posted Sep 12, 2026 - 02:32 EDT

Investigating

We are investigating reports of problems with one or more ITS services. Updates will be provided as they become available.
Posted Sep 12, 2026 - 00:16 EDT

Identified

We are investigating reports of problems with one or more ITS services. Updates will be provided as they become available.
Posted Sep 12, 2026 - 00:15 EDT

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Sep 12, 2026 - 00:10 EDT
This incident affected: TeamDynamix.