A water pipe has burst in the area which is delaying the running on the new cable. We will continue to monitor the repair progress.
Posted Sep 01, 2026 - 18:55 EDT
Identified
As part of our ongoing efforts to restore service, repair crews have located the damage between Ahoskie and Elizabeth City, NC, and are currently preparing new temporary cable. We will continue to monitor the repair progress and provide updates as available.
Posted Sep 01, 2026 - 16:29 EDT
Update
Provider partial fiber outage and they are working the issue at this time. NO ETR at this time.
Posted Sep 01, 2026 - 11:33 EDT
Investigating
Our monitoring tools have indicated a possible network issue at IMS Coastal Processes Environmental Health Lab. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Sep 01, 2026 - 10:57 EDT
This incident affected: Network (Campus Building Networks).