UNC WordPress Websites Not Loading

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Resolved – WordPress Multisite Networks Restored

Posted Jun 25, 2026 - 15:35 EDT

Monitoring

The WordPress sites.unc.edu network is recovered.

ITS-DigitalServices has been actively mitigating a high volume of malicious traffic and distributed attacks from bad actors.

Digital Services will continue to monitor the service.
Posted Jun 25, 2026 - 10:52 EDT

Investigating

Various UNC websites may be unable to load at this time. Engineers have been engaged and are working towards resolution.
Posted Jun 25, 2026 - 09:49 EDT
This incident affected: Web (Sites WordPress).