Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2026 - 17:00 EDT
Scheduled
HR will be updating a flag for positions as requested from a school that will trigger messages to IAM. We are expecting around 20,000 updates. IAM will process around 5,000 per hour. LDAP updates may experience slowness between 5:00PM and 7:00PM on 05/14/2026.
Posted May 13, 2026 - 15:46 EDT
This scheduled maintenance affected: Identity Access Management (LDAP).