Possible Issue Detected with ConnectCarolina Student Admin

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Logged into Connect Carolina, no issues at this time, On duty Mgr also logged in and no issues to report.

Posted Aug 03, 2026 - 10:21 EDT

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Aug 03, 2026 - 10:09 EDT
This incident affected: ConnectCarolina (ConnectCarolina Student Admin).