Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 17:00 EDT
Scheduled
ITS Rightfax service will be unavailable during this after-hours operating system software update. This scheduled outage is solely for the purpose of loading necessary updates to the system software. Rightfax application software will NOT be changed during this maintenance window.
Posted Mar 18, 2025 - 12:50 EDT
This scheduled maintenance affected: Other Services.