Craig North Experiencing Power Related Issues
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 03:16 EDT
Monitoring
Power has been restored to Craig North. We will continue to monitor the situation.
Posted Jul 30, 2020 - 02:51 EDT
Identified
We are aware that Craig North is currently experiencing building electrical issues. Campus personnel are currently working to resolve the situation and a generator is being dispatched to help maintain building power.
Posted Jul 30, 2020 - 02:35 EDT
This incident affected: Network (Campus Location(s)).