Franklin Street, 523 East Network Problem Detected

Incident Report for UNC Chapel Hill - ITS

Update

523 East Franklin Street (the old library) is currently down. The towns fiber extends to that building and a tree fell Saturday night at the intersection of Manning and Columbia and looks like it took out two 144 count fibers. Engineers have contacted the vendor with the town of Chapel Hill and they are working the issue with no ETR at this time.
Posted Jul 27, 2026 - 11:40 EDT

Investigating

Our monitoring tools have indicated a possible network issue at Franklin Street, 523 East. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Jul 25, 2026 - 19:17 EDT
This incident affects: Network (Campus Building Networks).