Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 19, 2023 - 17:00 EDT
Scheduled
Service maintenance will be performed on the main campus firewall. This should have little to no impact to the campus network. Change Request # CHG0041505
Posted Sep 13, 2023 - 09:38 EDT
This scheduled maintenance affected: Security (Main Campus Firewall Services).