This incident has been resolved. The service provider will continue monitoring the service overnight; however, no further issues are expected.
Posted Jul 30, 2026 - 19:25 EDT
Update
The service provider continues to work on resolving the issue and determining the root cause. We will provide another update as soon as it is received.
Posted Jul 30, 2026 - 13:43 EDT
Investigating
PING - desktop and mobile software for placing and receiving phone calls - is experiencing issues with connectivity. We have reported the issue to the provider and will post updates as known.