Possible Issue Detected with Canvas

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Vendor has resolved this issue and normal operations have been sustained after monitoring.

Posted Jul 16, 2026 - 14:31 EDT

Update

Cloudfront is still working on the issue with no ETR. Canvas has recovered at this time though, and is stable thus far.
Posted Jul 16, 2026 - 07:43 EDT

Update

There is a larger issue with CloudFront which is affecting Instructure services. Amazon technicians are working on restoration.
Posted Jul 16, 2026 - 05:11 EDT

Update

Instructure has acknowledged the issue and they are investigating per their status page. Updates will be provided as they become available.
Posted Jul 16, 2026 - 04:34 EDT

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Jul 16, 2026 - 04:02 EDT
This incident affected: Educational Technologies (Canvas).