Service Desk phone line (919-962-HELP) down

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:03 EDT

Identified

The service provider for the Service Desk phone line is currently unavailable due to the AWS outage. To contact the Service Desk please use the Chat in the lower right corner at help.unc.edu.
Posted Oct 20, 2025 - 10:21 EDT
This incident affected: Other Services.