The network provider has identified a fiber cut impacting Morehead City. There is no current estimated time of repair.
Posted Mar 17, 2026 - 14:15 EDT
Investigating
Our monitoring tools have indicated a possible network issue at IMS Coastal Processes Environmental Health Lab. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Mar 17, 2026 - 14:01 EDT
This incident affected: Network (Campus Building Networks).