VoicetThread Performance Degraded

Incident Report for UNC Chapel Hill - ITS

Resolved

Site has been stable after monitoring.
Posted Oct 20, 2025 - 18:38 EDT

Identified

VoiceThread is currently still having some issues due to the AWS outage this morning. Engineers are aware of the problem and working to resolve.
Posted Oct 20, 2025 - 09:48 EDT
This incident affected: Educational Technologies (Voicethread).