Reports of power outage in the area of Finley / Cone-Kenfield Tennis Center. Duke Power expects restoration by around 12:45am.
Posted Dec 18, 2025 - 21:13 EST
Investigating
Our monitoring tools have indicated a possible network issue at Finley Maintenance Building/Offices. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Dec 18, 2025 - 20:57 EST
This incident affected: Network (Campus Building Networks).