Phone Call Quality Degraded

Incident Report for UNC Chapel Hill - ITS

Monitoring

The issue appears to be resolved but the vendor is monitoring . Updates will be provided as they become available.
Posted May 01, 2026 - 15:35 EDT

Investigating

ITS Telecommunications is currently experiencing intermittent issues with inbound and outbound calls where static may be heard, or the call may not be completed. A ticket has been opened with the carrier and updates will be provided as they become available.
Posted May 01, 2026 - 13:06 EDT
This incident affects: Other Services.