Duke Energy Maintenance

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Maintenance complete.

Posted Jan 23, 2026 - 12:10 EST

Monitoring

Duke Energy is currently performing infrastructure upgrades close to campus, resulting in the loss of power for multiple buildings on and near Finley Golf Course Road. Estimated time of restoration is currently listed as January 23, 3:00 p.m.
Posted Jan 23, 2026 - 11:31 EST