Power Outage Impacting South Campus

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Energy Services has advised that this issue has been resolved. There are a few networking devices that didn't return to service after the power was restored. Appropriate groups are investigating these remaining devices.

Posted Sep 04, 2026 - 16:24 EDT

Identified

There is a large power outage that is impacting multiple south campus buildings. Appropriate teams are aware and investigating. There is no ETA on resolution at this time.
Posted Sep 04, 2026 - 15:34 EDT
This incident affected: Network (Campus Building Networks).