TIM currently unavailable

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 19:00 EDT

Investigating

TIM is currently unavailable; the vendor is actively working to resolve the issue and updates will be communicated as they become available.
Posted Mar 12, 2026 - 14:15 EDT
This incident affected: TIM.