TDX Performance Degredation When Loading Dashboard Charts

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 10:36 EST

Investigating

TDX is experiencing performance degradation when loading dashboard charts. No other services within the platform are currently impacted. The vendor is currently investigating the root cause.
Posted Nov 23, 2025 - 11:29 EST
This incident affected: TeamDynamix.