There appears to be power issues in the area that are impacting network connectivity at this location.
Posted Sep 23, 2023 - 15:15 EDT
Investigating
Our monitoring tools have indicated a possible network issue at Wilson Street, 205. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Sep 23, 2023 - 15:12 EDT
This incident affected: Network (Campus Building Networks).