Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 06, 2026 - 05:00 EST
Scheduled
Friday March 6th 5-7AM Craige North Dorm will be undergoing network Switching maintenance and during these hours the network at Craige North Dorm will be down and back to normal operation after 7AM.
Posted Mar 04, 2026 - 09:42 EST
This scheduled maintenance affected: Other Services.