Connect Carolina Student and Finance are now online. Connect Carolina HR is expected to return to service shortly.
Posted Oct 27, 2025 - 08:08 EDT
Update
Technical teams are aware of the issue and actively working to resolve.
Posted Oct 27, 2025 - 07:47 EDT
Investigating
Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Oct 27, 2025 - 07:33 EDT
This incident affected: ConnectCarolina (ConnectCarolina Student Admin).