Major Incident #467718 power issue

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 11:47 EDT

Update

We are continuing to investigate this issue.
Posted Sep 14, 2026 - 10:54 EDT

Investigating

A power issue is causing limited VOIP service degradation. The Network Engineering team is confirming details to minimize the impact and fully restore service.

We are currently aware of outages at Baity Hill and South Building.
Posted Sep 14, 2026 - 10:53 EDT
This incident affected: Other Services.