TDX went down for about a minuet and is now moving very slow.

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

The vendor has given the all clear and that normal processing has resumed.

Posted Nov 06, 2025 - 14:50 EST

Update

We are investigating issues with TDX having long load times. Engineers are engaged to resolve the issue.
Posted Nov 06, 2025 - 13:43 EST

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Nov 06, 2025 - 13:38 EST
This incident affected: TeamDynamix.