Possible Issue Detected with TeamDynamix

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Service was validated and resolved on it's own

Posted Jul 17, 2026 - 22:44 EDT

Investigating

Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Jul 17, 2026 - 22:22 EDT
This incident affected: TeamDynamix.