This incident has been resolved as a monitoring false positive or brief interruption.
Posted Nov 11, 2024 - 20:39 EST
Investigating
Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Nov 11, 2024 - 20:35 EST
This incident affected: Educational Technologies (Canvas).