TeamDynamix Investigating Reports of Unhandled Errors

Incident Report for UNC Chapel Hill - ITS

Resolved

TeamDynamix deployed a fix to address unhandled errors when accessing tickets in Work Management. The issue was caused by a misconfiguration during a maintenance deployment and has now been fully resolved.
Posted Dec 05, 2025 - 21:43 EST

Investigating

TeamDynamix is currently investigating reports of unhandled errors when accessing tickets in Work Management.
Posted Dec 05, 2025 - 21:36 EST
This incident affected: TeamDynamix.