Power outage causing service interruption at Outdoor Education Center
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 12:01 EDT
Identified
Issue is due to tree falling on power lines.
Posted Jul 29, 2022 - 07:55 EDT
This incident affected: Network (Campus Location(s)).