Encrypted External Emails
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 11:13 EDT
Identified
Emails sent from UNC accounts to external email addresses are being sent encrypted. ITS staff are aware and working to resolve the issue.
Posted Jun 16, 2020 - 10:51 EDT
This incident affected: Office 365.