Major AWS Outage (US-East)

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

Services have been restored

Posted Oct 20, 2025 - 07:39 EDT

Monitoring

AWS Engineers continue to observe recovery across most of the affected AWS Services. They can confirm global services and features that rely on US-EAST-1 have also recovered.
Posted Oct 20, 2025 - 06:18 EDT

Investigating

AWS Engineers are seeing significant signs of recovery. Most requests should now be succeeding. We continue to work through a backlog of queued requests. We will continue to provide additional information. Updates will be provided as they become available.
Posted Oct 20, 2025 - 05:58 EDT

Identified

The ITS Operations Center has detected an issue impacting one or more of our services. There is a major outage in the AWS region where many UNC resources (as well as UNC service providers) reside. UNC resources may be affected intermittently. AWS engineers have identified a potential root cause and continue to investigate trouble.
Posted Oct 20, 2025 - 05:39 EDT
This incident affected: Educational Technologies (Canvas, Voicethread) and TeamDynamix, Zoom.