Zoom Reporting Issues
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 17:08 EDT
Investigating
Zoom is currently reporting issues connecting to meetings and webinars. See status.zoom.us
Posted Oct 07, 2020 - 16:41 EDT
This incident affected: Other Services.