Teacch - Wilmington II Network Problem Detected

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted 18 days ago. Mar 20, 2025 - 00:25 EDT

Investigating

Our monitoring tools have indicated a possible network issue at Teacch - Wilmington II. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted 18 days ago. Mar 20, 2025 - 00:24 EDT
This incident affected: Network (Campus Building Networks).