Vendor fix appears to have addressed the issue and sites are recovering. UNC Engineers are awaiting the final all clear from the vendor.
Posted Jun 03, 2026 - 18:44 EDT
Investigating
UNC Engineers advise that this could also affect domains only serving as redirects that use the clinics.unc.edu root SSL cert.
Posted Jun 03, 2026 - 16:05 EDT
Identified
UNC Engineers advise that this issue impacts 124 sites with expired ssl certs tied to common name clinics.unc.edu. The vendor is working to resolve this issue.
Posted Jun 03, 2026 - 15:52 EDT
Investigating
There is an SSL Certificate issue that is impacting the UNC WordPress sites. This issue is being investigated by Engineers that are working with the vendor on a resolution.