Vendor advises that the issue is resolved and the UNC instance has been stable after monitoring.
Posted Oct 20, 2025 - 20:55 EDT
Monitoring
According to the Canvas vendor team, "Canvas is now accessible, and engineers are monitoring for stability." Tests to the UNC Campus instance show the site is back and responding.
Posted Oct 20, 2025 - 19:28 EDT
Identified
Canvas is currently down for an unscheduled maintenance due to the AWS outage this morning. More information can be found at https://status.instructure.com/
Posted Oct 20, 2025 - 09:42 EDT
Investigating
Monitoring systems are indicating a possible issue with one or more of our services. The ITS Operations Center is validating and engaging relevant teams. More information with be posted as it becomes available.
Posted Oct 20, 2025 - 09:38 EDT
This incident affected: Educational Technologies (Canvas).